nix-output-monitor/default.nix
maralorn 39f8530ae4
All checks were successful
Nix build / nix-build (default) (push) Successful in 10s
Nix build / nix-flake-check (push) Successful in 15s
Release 2.1.2
2024-01-26 00:40:09 +01:00

39 lines
1.6 KiB
Nix

{ mkDerivation, ansi-terminal, async, attoparsec, base, bytestring
, cassava, containers, data-default, directory, extra, filepath
, hermes-json, HUnit, lib, lock-file, MemoTrie, nix-derivation
, optics, random, relude, safe, stm, streamly-core, strict
, strict-types, terminal-size, text, time, transformers
, typed-process, unix, word8
}:
mkDerivation {
pname = "nix-output-monitor";
version = "2.1.2";
src = ./.;
isLibrary = true;
isExecutable = true;
libraryHaskellDepends = [
ansi-terminal async attoparsec base bytestring cassava containers
data-default directory extra filepath hermes-json lock-file
MemoTrie nix-derivation optics relude safe stm streamly-core strict
strict-types terminal-size text time transformers word8
];
executableHaskellDepends = [
ansi-terminal async attoparsec base bytestring cassava containers
data-default directory extra filepath hermes-json lock-file
MemoTrie nix-derivation optics relude safe stm streamly-core strict
strict-types terminal-size text time transformers typed-process
unix word8
];
testHaskellDepends = [
ansi-terminal async attoparsec base bytestring cassava containers
data-default directory extra filepath hermes-json HUnit lock-file
MemoTrie nix-derivation optics random relude safe stm streamly-core
strict strict-types terminal-size text time transformers
typed-process word8
];
homepage = "https://github.com/maralorn/nix-output-monitor";
description = "Processes output of Nix commands to show helpful and pretty information";
license = lib.licenses.agpl3Plus;
mainProgram = "nom";
}