config/iso.nix
maralorn 45dc91d7dd
All checks were successful
Nix build / nix-build (nixosConfigurations.apollo.config.system.build.toplevel) (push) Successful in 58s
Nix build / nix-build (nixosConfigurations.athene.config.system.build.toplevel) (push) Successful in 33s
Nix build / nix-build (nixosConfigurations.hephaistos.config.system.build.toplevel) (push) Successful in 48s
Nix build / nix-build (nixosConfigurations.hera.config.system.build.toplevel) (push) Successful in 28s
Nix build / nix-build (nixosConfigurations.zeus.config.system.build.toplevel) (push) Successful in 1m1s
Nix build / nix-flake-check (push) Successful in 2m56s
Configure iso
2024-02-13 02:11:03 +01:00

39 lines
706 B
Nix

{ pkgs, ... }:
{
nixpkgs.overlays = [
(_: super: {
zfs = super.zfs.overrideAttrs (_: {
meta.platforms = [ ];
});
})
];
environment.systemPackages = [
pkgs.helix
pkgs.fd
pkgs.htop
pkgs.tree
pkgs.lazygit
];
nix.settings.experimental-features = [
"nix-command"
"flakes"
"repl-flake"
];
boot = {
supportedFilesystems = [ "bcachefs" ];
kernelPackages = pkgs.linuxPackages_latest;
};
#boot.supportedFilesystems = [ "bcachefs" ];
console = {
earlySetup = true;
font = "${pkgs.spleen}/share/consolefonts/spleen-6x12.psfu";
keyMap = "neo";
};
isoImage.squashfsCompression = "gzip -Xcompression-level 1";
}